
G2 Engineering

Unit Conversion
User’s Guide

Version 2.3 Rev. 0



G2 Engineering Unit Conversion User’s Guide, Version 2.3 Rev. 0

December 2013

The information in this publication is subject to change without notice and does not represent a 
commitment by Gensym Corporation. 

Although this software has been extensively tested, Gensym cannot guarantee error-free 
performance in all applications. Accordingly, use of the software is at the customer’s sole risk. 

Copyright (c) 1985-2013 Gensym Corporation 

All rights reserved. No part of this document may be reproduced, stored in a retrieval system, 
translated, or transmitted, in any form or by any means, electronic, mechanical, photocopying, 
recording, or otherwise, without the prior written permission of Gensym Corporation. 

Gensym®, G2®, Optegrity®, and ReThink® are registered trademarks of Gensym Corporation. 

NeurOn-Line™, Dynamic Scheduling™ G2 Real-Time Expert System™, G2 ActiveXLink™, G2 
BeanBuilder™, G2 CORBALink™, G2 Diagnostic Assistant™, G2 Gateway™, G2 GUIDE™, 
G2GL™, G2 JavaLink™, G2 ProTools™, GDA™, GFI™, GSI™, ICP™, Integrity™, and SymCure™ 
are trademarks of Gensym Corporation.

Telewindows is a trademark or registered trademark of Microsoft Corporation in the United States 
and/or other countries. Telewindows is used by Gensym Corporation under license from owner.

This software is based in part on the work of the Independent JPEG Group.

Copyright (c) 1998-2002 Daniel Veillard.  All Rights Reserved. 

SCOR® is a registered trademark of PRTM. 

License for Scintilla and SciTE, Copyright 1998-2003 by Neil Hodgson, All Rights Reserved.

This product includes software developed by the OpenSSL Project for use in the OpenSSL Toolkit 
(http://www.openssl.org/). 

All other products or services mentioned in this document are identified by the trademarks or 
service marks of their respective companies or organizations, and Gensym Corporation disclaims 
any responsibility for specifying which marks are owned by which companies or organizations. 

Gensym Corporation 
52 Second Avenue
Burlington, MA 01803 USA
Telephone: (781) 265-7100
Fax: (781) 265-7101 Part Number: DOC011-830 



Contents
About v

Audience v

Conventions vi

Related Documentation vii

Customer Support Services x

Chapter 1 Introduction to G2 Engineering Unit Conversion 1

Loading GEUC 1

Chapter 2 Module Settings 3

geuc-module-settings 4

Configuration File 6

Chapter 3 Converting Engineering Units 7

Working with Engineering Unit Conversions 8
Configuring External Datapoint Units in the CSV File 8

Viewing Built-in Engineering Unit Conversion Definitions 9

Defining Engineering Unit Conversion Synonyms 11
Adding New Synonyms to Existing Engineering Unit Conversion 

Definitions 12
Creating New Engineering Units and Synonyms 14

Defining Engineering Unit Conversion Definitions 17

Converting Engineering Units on Demand 21

Managing Engineering Units 21
Managing Engineering Unit Conversions 22
Managing Engineering Unit Synonyms 22

Chapter 4 Customizing Engineering Units 25

Dimension Types 26

Dimension Units 27
iii



Conversion Status 28

API Procedures 29

Index 31
iv



Preface
Describes this guide and the conventions that it uses.

About this Guide v

Audience v

Conventions vi

Related Documentation vii

Customer Support Services x

About this Guide
This guide describes the G2 Engineering Unit Conversion (GEUC) module. This 
module provides numerous built-in units and unit conversion, and allows you to 
create custom unit conversions and synonyms.

Audience
This guide is for G2 developers who want to customize applications, using a set of 
standard application programmers’ interface (API) procedures and methods, and 
built-in classes. It assumes familiarity with the G2 procedure language. 
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Conventions
This guide uses the following typographic conventions and conventions for 
defining system procedures.

Typographic

Convention Examples Description 

g2-window, g2-window-1, 
ws-top-level, sys-mod

User-defined and system-defined 
G2 class names, instance names, 
workspace names, and 
module names

history-keeping-spec, temperature User-defined and system-defined 
G2 attribute names

true, 1.234, ok, “Burlington, MA” G2 attribute values and values 
specified or viewed through 
dialogs

Main Menu > Start

KB Workspace > New Object

create subworkspace

Start Procedure

G2 menu choices and button labels

conclude that the x of y ... Text of G2 procedures, methods, 
functions, formulas, and 
expressions

new-argument User-specified values in 
syntax descriptions

text-string Return values of G2 procedures 
and methods in syntax 
descriptions

File Name, OK, Apply, Cancel, 
General, Edit Scroll Area

GUIDE and native dialog fields, 
button labels, tabs, and titles

File > Save

Properties

GMS and native menu choices

workspace Glossary terms
vi



Related Documentation
Note Syntax conventions are fully described in the G2 Reference Manual.

Procedure Signatures

A procedure signature is a complete syntactic summary of a procedure or 
method. A procedure signature shows values supplied by the user in italics, and 
the value (if any) returned by the procedure underlined. Each value is followed by 
its type:

g2-clone-and-transfer-objects 
(list: class item-list, to-workspace: class kb-workspace, 
delta-x: integer, delta-y: integer) 

-> transferred-items: g2-list

Related Documentation 

G2 Core Technology 

• G2 Bundle Release Notes 

• Getting Started with G2 Tutorials 

• G2 Reference Manual

• G2 Language Reference Card

• G2 Developer? Guide 

• G2 System Procedures Reference Manual 

c:\Program Files\Gensym\ Windows pathnames

/usr/gensym/g2/kbs UNIX pathnames

spreadsh.kb File names

g2 -kb top.kb Operating system commands

public void main()
gsi_start

Java, C and all other external code

Convention Examples Description 
vii



• G2 System Procedures Reference Card 

• G2 Class Reference Manual 

• Telewindows User? Guide 

• G2 Gateway Bridge Developer? Guide 

G2 Utilities 

• G2 ProTools User? Guide

• G2 Foundation Resources User? Guide 

• G2 Menu System User? Guide 

• G2 XL Spreadsheet User? Guide 

• G2 Dynamic Displays User? Guide 

• G2 Developer? Interface User? Guide 

• G2 OnLine Documentation Developer? Guide 

• G2 OnLine Documentation User? Guide 

• G2 GUIDE User? Guide 

• G2 GUIDE/UIL Procedures Reference Manual 

G2 Developers’ Utilities

• Business Process Management System User? Guide

• Business Rules Management System User? Guide

• G2 Reporting Engine User? Guide

• G2 Web User? Guide

• G2 Event and Data Processing User? Guide

• G2 Run-Time Library User? Guide

• G2 Event Manager User? Guide

• G2 Dialog Utility User? Guide

• G2 Data Source Manager User? Guide

• G2 Data Point Manager User? Guide

• G2 Engineering Unit Conversion User? Guide

• G2 Error Handling Foundation User? Guide

• G2 Relation Browser User? Guide
viii
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Bridges and External Systems 

• G2 ActiveXLink User? Guide

• G2 CORBALink User? Guide

• G2 Database Bridge User? Guide

• G2-ODBC Bridge Release Notes

• G2-Oracle Bridge Release Notes

• G2-Sybase Bridge Release Notes

• G2 JMail Bridge User? Guide

• G2 Java Socket Manager User? Guide

• G2 JMSLink User? Guide

• G2-OPC Client Bridge User? Guide

• G2 PI Bridge User? Guide
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Customer Support Services
You can obtain help with this or any Gensym product from Gensym Customer 
Support. Help is available online, by telephone, by fax, and by email.

To obtain customer support online:

 Access G2 HelpLink at www.gensym-support.com. 

You will be asked to log in to an existing account or create a new account if 
necessary. G2 HelpLink allows you to:

• Register your question with Customer Support by creating an Issue.

• Query, link to, and review existing issues.

• Share issues with other users in your group. 

• Query for Bugs, Suggestions, and Resolutions.

To obtain customer support by telephone, fax, or email:

 Use the following numbers and addresses: 

Americas Europe, Middle-East, Africa (EMEA)

Phone (781) 265-7301 +31-71-5682622

Fax (781) 265-7255 +31-71-5682621

Email service@gensym.com service-ema@gensym.com
x
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Introduction to G2
Engineering Unit Conversion
Provides an overview of the G2 Engineering Unit Conversion (GEUC) module.

Introduction
The G2 Engineering Unit Conversion (GEUC) module provides a way of 
specifying the engineering units for entering and displaying values, as well as a 
large number of synonyms for those conversions in both the English and metric 
systems. GEUC defines a large set of built-in engineering unit conversions and 
synonyms for dimensions such as pressure, length, volume, volumetric flow, 
mass, density, temperature, power, heat transfer, and time. It also provides a 
mechanism for defining custom dimensions, engineering units, and synonyms.

When you create external datapoints from a CSV file, using the G2 Data Point 
Management (GDPM) module, for example, you specify the engineering units 
that the DCS system uses for datapoints, which are known as the field units. You 
can configure the units that GEUC uses for entering property values and 
displaying computed metrics, which are known as the user units or external 
units. GEUC converts all field units and external units to a set of common units 
that it uses for its internal calculations, which are known as internal units. 

In addition, GEUC provides API procedures and functions that you can call to 
work with engineering unit conversions programmatically.

Loading GEUC
To use the GEUC module, you must load or merge in geuc.kb, which is located in 
the g2i\kbs directory. 
1
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Module Settings
Describes the G2 Engineering Unit Conversion (GEUC) module settings.

Introduction 3

geuc-module-settings 4

Configuration File 6

Introduction
The geuc-module-settings object inherits GFR module settings. Upon startup, 
GFR locates one module settings object as the active setting, which is typically the 
instance in the highest level module. The active module is determined when G2 is 
started. Several APIs take the active module settings object into account during 
execution. 
3



geuc-module-settings
Manages system configurations for the GEUC module.

Class Inheritance Path

gfr-module-settings, object, item 

Attributes

Attribute Description 

data-directory The directory in which to store conversion and 
synonym files. 

Allowable values: text

Default value: "“

Notes: See Configuration File.

packaged-conversion-
filename

The name of the file in which built-in unit 
conversions are stored.

Allowable values: text

Default value: conversions.csv

packaged-conversion-
filename-backup

The name of the backup file for built-in unit 
conversions.

Allowable values: text

Default value: conversions.old

custom-conversions-
filename

The name of the file in which to store custom 
unit conversions.

Allowable values: text

Default value: custom-conversions.csv
4



geuc-module-settings
custom-conversions-
filename-backup

The name of the backup file for custom unit 
conversions.

Allowable values: text

Default value: custom-conversions.old

packaged-synonyms-
filename

The name of the file in which built-in synonyms 
are stored.

Allowable values: text

Default value: synonyms.csv

packaged-synonyms-
filename-backup

The name of the backup file for built-in 
synonyms.

Allowable values: text

Default value: synonyms.old

custom-synonyms-
filename

The name of the file in which to store custom 
synonyms.

Allowable values: text

Default value: custom-synonyms.csv

custom-synonyms-
filename-backup

The name of the backup file for custom 
synonyms.

Allowable values: text

Default value: custom-synonyms.old

Attribute Description 
5



Configuration File
This table describes the settings in the configuration file (config.txt, by default), 
the associated group, and the attributes in the geuc-module-settings object that 
they configure at startup:

Group Configuration File Settings GDSM Module Settings Attributes

ENGINEERING-
UNITS

GEUC-DATA-DIRECTORY=
$APPLICATION-ROOT-
DIRECTORY/g2i/data

data-directory 
6
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Converting
Engineering Units
Describes how to convert engineering units.

Introduction 7

Working with Engineering Unit Conversions 8

Viewing Built-in Engineering Unit Conversion Definitions 9

Defining Engineering Unit Conversion Synonyms 11

Defining Engineering Unit Conversion Definitions 17

Converting Engineering Units on Demand 21

Managing Engineering Units 22

Introduction
This chapter describes how to:

• Work with engineering unit conversions.

• View built-in engineering unit conversion definitions.

• Define engineering unit conversion synonyms.

• Define engineering unit conversion definitions.

• Convert engineering units on demand.

• Manage engineering units.
7



Working with Engineering Unit Conversions
You work with engineering unit conversions in various ways in an application. 

Configuring External Datapoint Units in the CSV File

You can import units from the CSV file used for configuring external datapoints, 
using GDPM. You configure the Datapoint Units in the column to the right of the 
Datapoint Type column in the CSV file. The datapoint units that you configure 
are equivalent to the field units that domain objects use as sensor values. 

You can specify any of the built-in engineering units or a synonym. For 
information on determining the built-in engineering units, see Viewing Built-in 
Engineering Unit Conversion Definitions.

If you specify an engineering unit that does not exist, GEUC automatically creates 
a unit synonym definition and places it in the Undefined-Dimension category in 
the Unit Synonyms submenu. For more information, see Creating New 
Engineering Units and Synonyms.

Note Sometimes units provided in the DCS system are inaccurate, thus GEUC requires 
you to enter the units explicitly rather than obtaining them directly from the DCS 
system. 

Here is part of an external datapoint configuration file, which defines field units 
for several datapoints in the metric system:

Caution When upgrading older versions of GEUC, you must add the Units column to the 
CSV file before creating external datapoints. Creating external datapoints from a 
CSV file that does not include the Units column generates an error.
8



Viewing Built-in Engineering Unit Conversion Definitions
Viewing Built-in Engineering Unit Conversion 
Definitions

When configuring engineering units for a given dimension, you choose from a list 
of engineering units in the given system, either English or metric. Similarly, when 
configuring the units for external datapoints, you specify the engineering units in 
a CSV file. 

You can view the built-in engineering unit conversions for each dimension to see 
how they are defined. Each conversion definition specifies the following 
information:

• The dimension type, such as area, pressure, or temperature.

• The input and output units for the conversion.

• Whether the conversion defines a multiplier and/or offset.

• A multiplier and offset for the conversion. 

• Input and output synonyms. 

You might want to view the built-in engineering unit conversion definitions to see 
which synonyms are defined for the input and output units and whether you 
need to define additional synonyms.

For example, the area dimension defines an engineering unit conversion called 
square meter->square feet, which converts square meters to square feet. The 
input and output units define these synonyms:

Note The menu choices in this and the following sections assume that enable-menus-
and -toolbars-upon-startup is enabled in the grtl-module-settings object. For more 
information, see the G2 Run-Time Library User? Guide.

To view built-in engineering unit conversion definitions:

 Choose Project > System Settings > Units > Conversions, then choose the 
dimension and conversion definition you want to view.

Engineering Unit Synonyms

square meter m2 meter2

square feet ft2 foot2 feet2
9



For example, to view the conversion definition for the area dimension that 
converts square meters to square feet, you would choose:
10



Defining Engineering Unit Conversion Synonyms
Here is the Engineering Unit Conversion dialog for the square meter->square 
feet conversion definition. Notice that the conversion has three synonyms for 
square meter, and four synonyms for square feet. The conversion definition 
multiplies the input value by the specified multiplier to calculate the 
output value.

Defining Engineering Unit Conversion 
Synonyms

You can configure additional synonyms for any of the built-in engineering unit 
conversion definitions. You can also define new engineering units and synonyms 
to create new engineering conversion unit definitions.

Adding New Synonyms to Existing Engineering Unit 
Conversion Definitions

Suppose you want to add a new synonym called meters2 for the square meter 
engineering unit.

To add a new synonym to an existing engineering unit conversion definition:

1 Choose Project > System Settings > Units > Synonyms, then choose the 
dimension and corresponding conversion unit for which you want to define a 
new synonym.
11



For example, to add meters2 as a synonym for square meter, choose:

The Synonym Definition dialog appears with the packaged synonyms for the 
specified unit in the list on the left. 

2 To create a new synonym, click the New button in the Custom Synonyms list 
and enter a synonym.

3 To enter additional synonyms, click in the number column of the row where 
you want to insert a new synonym, and click the Insert Before or Insert After 
toolbar button to insert a new row before or after the selected row. 

4 Enter a new synonym in the new row.
12



Defining Engineering Unit Conversion Synonyms
5 Click OK in the dialog, then click OK in the confirmation dialog to save the 
synonym to the custom synonyms file.

Here is the Synonym Definition dialog that defines meters2 as a new synonym for 
the square meter unit:

The new synonym now appears in the Engineering Unit Conversion dialog for 
the conversion definition:
13



Creating New Engineering Units and Synonyms

Suppose you want to create a new engineering unit conversion definition for the 
area dimension that converts square centimeters to square inches. You would 
create two new engineering units called square centimeter and square inch, each 
of which might define several synonyms.

When you initially create new engineering units, they appear in the Undefined-
Dimension category in the Synonyms submenu. As soon as you create a new 
engineering unit conversion definition that uses the new conversion units, they 
appear in the appropriate dimension category in the submenu.

Note Any existing unit synonyms that have not yet been used as part of an engineering 
unit conversion definition appear in the Undefined-Dimensions category. 

To create a new engineering unit and synonyms:

1 Choose Project > System Settings > Units > Synonyms > Manage to display 
the Manage dialog for all the unit synonyms.

2 Click the New button to create a new engineering unit definition.

3 Configure the Synonym Key to be most generic form of the engineering unit.

4 To create a synonym, click the New button in the Custom Synonyms list and 
enter a synonym.

5 Click OK in the dialog, then click OK in the confirmation dialog to save the 
engineering unit and its synonyms to the custom synonyms file.

6 Repeat for the input and output engineering units required for the new 
engineering unit conversion definition. 
14



Defining Engineering Unit Conversion Synonyms
Here is the Synonym Definition dialog that defines the square centimeter 
engineering unit and two synonyms:

Here is the Synonym Definition dialog that defines the square inch engineering 
unit and two synonyms:
15



Initially, the new engineering units appear in the Undefined-Dimension category 
in the Synonyms menu, along with other engineering units that are not yet used 
in any engineering unit conversion definitions:
16



Defining Engineering Unit Conversion Definitions
Defining Engineering Unit Conversion 
Definitions

Once you have defined the input and output units and their synonyms, you can 
define a new engineering unit conversion definition that uses those engineering 
units. For example, you might want to create a new engineering unit conversion 
definition for the area dimension that converts square centimeters to square 
inches.

To do this, first, you must create the engineering units and synonyms for 
square centimeter and square inch, as described in Defining Engineering Unit 
Conversion Synonyms. 

To create a new engineering unit conversion definition:

1 Choose Project > System Settings > Units > Conversions > Manage to display 
the Manage dialog for all unit conversions.

2 Click the New button to create a new engineering unit conversion definition.

3 Configure the Dimension Class for the engineering unit conversion definition.

You can configure an existing dimension, such as area, or you can create a 
new dimension. For example, to create an engineering unit conversion called 
square centimeter->square inch, you would configure the dimension to be 
area.

4 Configure the Input Units and Output Units for the dimension.

In the example, the Input Units would be square centimeter and the Output 
Units would be square inch.

5 Configure the Equation Type to be one of the following:

• multiplier-only — Specifies a Multiplier only.

• offset-only — Specifies an Offset only.

• multiply-first — Specifies both a Multiplier and Offset, where the 
multiplication operation happens before the offset.

• offset-first — Specifies both an Offset and a Multiplier, where the offset 
operation happens before the multiplication.

6 Depending on the value of Equation Type, configure the Multiplier and Offset 
to be the values to use for multiplying and offsetting the input value to 
calculate the output value.

7 Click OK in the dialog, then click OK in the confirmation dialog to save the 
engineering unit conversion to the custom conversions file.
17



Here is the engineering unit conversion definition for square centimeter->square 
inch, which converts square centimeter to square inch, using a multiplier. Once 
you initially accept the dialog, the custom synonyms for the input and output 
units all appear in the dialog.
18



Defining Engineering Unit Conversion Definitions
The engineering unit conversion definition appears in the menus under the area 
dimension along with the built-in conversion definition:
19



Now that the custom engineering units have been used in an engineering unit 
conversion definition, they appear under the appropriate dimension in the 
menus, in this case, area. They no longer appear under the Undefined-Dimension 
category.
20



Converting Engineering Units on Demand
Converting Engineering Units on Demand
You can perform engineering unit conversions on demand through the 
Engineering Unit Converter dialog. You might want to do this to verify a unit 
conversion before choosing the units.

To convert engineering units on demand:

1 Choose Project > System Settings > Units > Converter.

2 Choose the Dimension type.

3 Configure the Input Units and the Output Units. 

4 Enter an Input Value in the input units and press Return.

The converted value in the output units appears with a status value of converted 
with a status of converted. The converted value also updates automatically if you 
change the Input Units and Output Units for a given Input Value.

Here is the Engineering Unit Converter dialog that shows the unit conversion 
from ft2 to m2:
21



Managing Engineering Units
You manage engineering unit conversions and synonyms separately.

Managing Engineering Unit Conversions

To manage engineering unit conversions:

1 Choose Project > System Settings > Units > Conversions > Manage.

All engineering unit conversion classes appear in the submenu, and all 
built-in and custom engineering unit conversions appear in the submenus for 
each conversion class. 

2 To configure the properties of a unit conversion, choose one from the 
appropriate category in the Unit Conversions submenu.

3 To display a dialog for managing all unit conversions, choose Manage.

Here is the Unit Conversions Manage dialog:

Managing Engineering Unit Synonyms

To manage engineering unit conversions:

1 Choose Project > System Settings > Units > Synonyms > Manage.

All engineering unit conversion classes appear in the submenu, and all 
built-in and custom engineering unit synonyms appear in the submenus for 
each conversion class. 

2 To configure the properties of a unit synonym, choose one from the 
appropriate category in the Unit Synonyms submenu.
22



Managing Engineering Units
3 To display a dialog for managing all unit synonyms, choose Manage.

Here is the Unit Synonyms Manage dialog:
23
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Customizing
Engineering Units
Describes how to customize engineering units.

Introduction 25

Dimension Types 26

Dimension Units 26

Conversion Status 27

API Procedures 29

Introduction
You can use the following API procedures and functions to work with 
engineering unit conversions programmatically your application. They provide 
the ability to:

• Convert values from one engineering unit to another for a given dimension.

• Convert from internal to external units, and from external to internal units for 
a given dimension.

• Get the internal units of a given dimension in either the metric or English 
system.

• Get the units for a given parameter of a sensor or controller.
25



Dimension Types
GEUC defines built-in engineering units for a number of dimension types, which 
it uses for displaying engineering units. The dimension types categorize the units 
that the various parameters and metrics require. 

In the API procedures and functions that follow, the dimension-type is one of 
these symbols: 

pressure
length
area
volume
volumetric-flow
volumetric-heat-capacity,
volumetric-enthalpy
mass
mass-flow
mass-heat-capacity
mass-enthalpy,
density
density-slope
specific-volume
temperature
power
heat-transfer,
time
molar-volume
voltage
current

Dimension Units
GEUC allows you to configure the units of a given dimension for entering 
parameters and displaying metrics for domain objects, in a given unit system. For 
example, if the unit system is metric and you are configuring the units for the 
process-pc of the Heater Efficiency derived sensor of a heater, you can choose 
from the following metric units:

kilojoule per cubic 
meter degree celsius

kj/m3-C kj/m3-deg C

joule per cubic meter 
degree celsius

j/m3-C j/m3-deg C
26



Conversion Status
Similarly, if the unit system is english, you would choose from these units:

In the API procedures and functions that follow, the dimension units that you 
specify as arguments should be one of the built-in synonyms, as a text. These are 
either input or output units, or internal or external units, depending on the API. 

Note that spaces are stripped from the units, so the spaces you enter do not 
matter.

Note If you enter a dimension unit that is not one of the built-in synonyms, GEUC 
automatically creates the specified unit synonym and places it in the Undefined-
Dimensions category in the Unit Synonyms dialog. Typically, undefined 
synonyms constitute typographical errors in the API procedure code. 

Conversion Status
The API procedures that convert engineering units all return the following status 
values, as a text, to indicate whether the conversion was successful:

kilocalorie per cubic 
meter degree celsius

kcal/m3-C kcal/m3-deg 
C

calorie per cubic meter 
degree celsius

cal/m3-C cal/m3-deg C

btu per cubic foot 
degree fahrenheit

btu/ft3-F btu/ft3-deg F

Status Description

converted A conversion definition was found and the input value 
was successfully converted.

undefined A conversion definition was not found because of an 
unrecognized dimension-type, input-units, or output-
units. This status can mean that either a conversion has 
not been defined, or that the user is supplying an input 
or output synonym for an existing conversion that is 
not yet recognized and needs to be added to the 
appropriate synonym definition. Check the API call for 
correct units, or create custom synonyms or custom 
conversion definitions, as needed.
27



unrecognized
equation type

The equation type for the conversion definition was not 
recognized as one of the following symbols:

MULTIPLIER-ONLY
MULTIPLY-FIRST
OFFSET-ONLY
OFFSET-FIRST

For custom conversions, modify the Equation Type. For 
built-in conversions, contact Gensym support.

missing eu organizer The GEUC organizer object is missing. This error can 
occur only if a user or procedure specifically deletes the 
packaged organizer object. Report occurrences of this 
status to Gensym support.

no sequence The requested dimension could not be matched in the 
GEUC conversion organizer object. Check the API call 
for the correct dimension. The API automatically 
creates an empty custom conversion definition, which 
you can edit through the manager.

zero multiplier The Multiplier for the requested conversion is zero, 
which would create a divide-by-zero error if executed. 
For custom conversions, update the Multiplier 
parameter and retry the unit conversion. For built-in 
conversion, contact Gensym support.

procedure abort A serious programming error occurred. Send G2 
Logbook error messages to Gensym support for 
analysis.

abort A serious programming error occurred. Send G2 
Logbook error messages to Gensym support for 
analysis.

Status Description
28



API Procedures
API Procedures
geuc-convert-engineering-units

(dimension-type: symbol, input-value: quantity, 
input-units: text, output-units: text)
-> output-value: quantity, status: text

Converts an input value to an output value of a given dimension, given the 
input and output units. 

geuc-load-custom-conversion-objects-from-file 
( )

Loads the custom conversion from the file. The file is automatically loaded 
upon startup. Use this API to reload the file.

geuc-load-custom-synonym-objects-from-file 
( )

Loads the custom synonyms from the file. The file is automatically loaded 
upon startup. Use this API to reload the file.

geuc-reload-conversions-and-synonyms
(directory: text, packaged-conversions-and-synonyms: truth-value)

Loads conversions and synonyms from the specified directory. This API 
always loads the custom files. If packaged-conversions-and-synonyms is true, it 
also loads the packaged conversions and synonyms. If the directory argument 
is empty, it loads them from the current directory in the GEUC module 
settings.

Argument Description

dimension-type The dimension type, as a symbol. See Dimension 
Types.

input-value The input value to convert. 

input-units The input units to use for the conversion, as a text.

output-units The output units to use for the conversion, as a text.

Return Value Description

output-value The converted output value in the given output 
units.

status The status of the conversion. See Conversion Status.
29
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